Issues with unRAID Installation

Helllo! I’ve tried to get LinkAce working on Unraid for a couple of weeks without success. I searched for LinkAce in the Community App Store and went with the official version. I followed the instructions on the Docker Page and I have not added any other paths or variables. On the picture below you can see the instructions provided on the docker page as well as the paths and variables the docker created automatically.

When I look at the log of the container it outputs the following information.

2021-12-06 15:37:28,713 INFO Set uid to user 0 succeeded
2021-12-06 15:37:28,715 INFO supervisord started with pid 1
2021-12-06 15:37:29,718 INFO spawned: 'php-fpm' with pid 7
2021-12-06 15:37:29,720 INFO spawned: 'nginx' with pid 8
[06-Dec-2021 15:37:29] NOTICE: fpm is running, pid 7
[06-Dec-2021 15:37:29] NOTICE: ready to handle connections
2021-12-06 15:37:30,742 INFO success: php-fpm entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-12-06 15:37:30,742 INFO success: nginx entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)

If I try to go to Local-Ip-of-server:4256 it is not possible to establish a connection. I have also tried setting up a ReverseProxy with NginxProxyManager for the local IP at linkace.mydomain.com, but that does not work either.

Here is a PasteBin of my .ENV-file. Does anyone know what is wrong and how I can fix it?

UPDATE: When I took a closer look, I noticed that the container were missing the PUID, PGID and UMASK variables that all my other containers have, so I tried to add them manually. I also noticed that the only file in my appdata/linkace folder was the .env as well as an empty folder named logs. So I added the docker-compose.yml, but neither of these steps changed anything.
image

I have not yet worked with Unraid, but the port looks wrong. Linkace is available at port 80 and I don’t know where port 4256 is coming from.
Are you sure that this port is correctly mapped to port 80 inside the container?

Turns out that the issue was the I had selected the wrong network type. Selecting the correct one fixed it.

1 Like