Issues with non-docker install and npm

Description of the Issue
Trying a fresh install without docker. Followed the instructions for “Setup without Docker” but at the /setup/start page I received the error:

## Missing Mix Manifest File
Did you forget to run `npm install && npm run dev`

So I installed npm and ran npm install but when I run npm run dev or npm run production I get the following:

> [email protected] production /var/www/linkace
> mix --production

/var/www/linkace/node_modules/laravel-mix/bin/cli.js:21
async function run() {
      ^^^^^^^^

SyntaxError: Unexpected token function
    at createScript (vm.js:56:10)
    at Object.runInThisContext (vm.js:97:10)
    at Module._compile (module.js:549:28)
    at Object.Module._extensions..js (module.js:586:10)
    at Module.load (module.js:494:32)
    at tryModuleLoad (module.js:453:12)
    at Function.Module._load (module.js:445:3)
    at Module.runMain (module.js:611:10)
    at run (bootstrap_node.js:394:7)
    at startup (bootstrap_node.js:160:9)

npm ERR! Linux 4.14.238-182.422.amzn2.x86_64
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "run" "production"
npm ERR! node v6.17.1
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE
npm ERR! [email protected] production: `mix --production`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] production script 'mix --production'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the linkace package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     mix --production
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs linkace
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls linkace
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /var/www/linkace/npm-debug.log

npm-debug.log doesn’t seem to have any additional information.

LinkAce setup (please complete the following information):

  • Version: 1.6.4
  • Installed via: PHP 7.4, Apache
  • OS: Amazon Linux 2 (Amazon EC2 instance)

I actually have another instance of LinkAce running, just not on an Amazon EC2 instance, though it was installed a while ago and subsequently upgraded.

This is resolved and was due to user error.

I had installed LinkAce using git clone. When I instead downloaded the release zip file everything worked fine.

I thought at one point the documentation had a scenario of using git clone, but maybe I’m thinking of another application.

Thanks for your report.

The readme had a guide for using git clone but it is intended for developers.

For users facing similar issues: please update your Node version. LinkAce requires at least v12, but I only use v14 for testing.