Installation page "<my-ip>/setup/start" not found

Description of the Issue
Followed this instruction https://www.linkace.org/docs/v1/setup/setup-without-docker/

Change Apache default config DocumentRoot to “DocumentRoot /var/www/html/linkace/public”

Call “http://” from Desktop

I get “404 Not Found” - Page “/setup/start” doesn’t exist

LinkAce setup (please complete the following information):

  • Version: 1.5.0
  • Installed via: PHP
  • OS: Ubuntu 20.04 LTS (latest version)

Desktop (please complete the following information if applicable):

  • OS: Mac OS and Win10
  • Browser Chrome
  • Version latest

Additional context

Hi!
Is it a generic error page from Apache?
I could take a look but I am not using any Apache servers anymore so it might take a while.

Hi Kevin,
thanks a lot for taking care, as I really liked the demo and think the tool is great.
See error log in in addition:

[email protected]:/home/linkaceadmin# tail -f /var/log/apache2/error.log
[Fri Apr 09 15:58:28.476163 2021] [core:info] [pid 2545] [client 172.20.4.199:56713] AH00128: File does not exist: /var/www/html/linkace/public/setup/start
[Fri Apr 09 15:58:28.595969 2021] [authz_core:debug] [pid 2545] mod_authz_core.c(817): [client 172.20.4.199:56713] AH01626: authorization result of Require all granted: granted, referer: http://linkace.degel.ch/setup/start
[Fri Apr 09 15:58:28.596030 2021] [authz_core:debug] [pid 2545] mod_authz_core.c(817): [client 172.20.4.199:56713] AH01626: authorization result of : granted, referer: http://linkace.degel.ch/setup/start
[Fri Apr 09 16:38:26.266261 2021] [authz_core:debug] [pid 2544] mod_authz_core.c(817): [client 172.20.4.190:63724] AH01626: authorization result of Require all granted: granted
[Fri Apr 09 16:38:26.266431 2021] [authz_core:debug] [pid 2544] mod_authz_core.c(817): [client 172.20.4.190:63724] AH01626: authorization result of : granted
[Fri Apr 09 16:38:26.266720 2021] [authz_core:debug] [pid 2544] mod_authz_core.c(817): [client 172.20.4.190:63724] AH01626: authorization result of Require all granted: granted
[Fri Apr 09 16:38:26.266742 2021] [authz_core:debug] [pid 2544] mod_authz_core.c(817): [client 172.20.4.190:63724] AH01626: authorization result of : granted
[Fri Apr 09 16:38:26.314812 2021] [authz_core:debug] [pid 2543] mod_authz_core.c(817): [client 172.20.4.190:63725] AH01626: authorization result of Require all granted: granted
[Fri Apr 09 16:38:26.314859 2021] [authz_core:debug] [pid 2543] mod_authz_core.c(817): [client 172.20.4.190:63725] AH01626: authorization result of : granted
[Fri Apr 09 16:38:26.314925 2021] [core:info] [pid 2543] [client 172.20.4.190:63725] AH00128: File does not exist: /var/www/html/linkace/public/setup/start

I am not sure what the problem might be. I searched for similar problems but had no luck so far.
Could you post (or privately send me) the regular access logs?
Also, please verify that mod rewrite is installed and enabled and PHP has the correct version.

I, too, had this happen. I resolved it and here is what I needed to do.

If you type a2enmod -l does it list rewrite? It didn’t for me and so I type a2enmod rewrite to add the rewrite module (and the restart Apache service).

That still didn’t do it. Next go to your Apache configuration directory (/etc/apache). In the configuration file (mine is called default-server.conf but yours might be called httpd.conf or similar) you probably have a line that might look like:
Options None

I changed mine to:
Options All

Also a line like:
AllowOverride None

I changed to:
AllowOverride All

Then restart Apache service. These suggestions are to get it working. After that be sure to go back and consider the options and choose the correct ones for your situation.

Hope that helps! :smiley:

1 Like