Installation on RPI4 ARM64

Description of the Issue
For Docker (advanced setup)

  1. Advanced setup pulls incompatible images for ARM64

For Docker (simple setup)

  1. “.env file not present and readable” (Similar to other post)
  2. Setup cannot complete if passwords are changed (Similar to other post)

Steps to reproduce
Follow instructions for “Setup with Docker (Advanced)”
Follow instructions for “Setup with Docker (Simple)”

Expected behavior
Container completes setup with no problems and can run.

LinkAce setup (please complete the following information):

  • Version: latest
  • Installed via: Docker
  • OS: Raspberry PI OS 64 bit (ARM64)

Additional context
Just tried to do the advanced setup on my RPI4 but noticed the nginx and redis images pulled were not ARM64 compatible so it would show an exec user error in the logs.

The simple setup works fine, however similar to the other posts here, I had to keep the default password unchanged. I did not use any quotation marks, and I thought my password having special symbols was the cause but even if it was only letters and numbers, it still would not work.

The .env file not present and readable problem, even though file was present in the folder, was easily solved by changing the file’s permissions. Can permissions be changed back after the setup?

Yes please! The file needs to be writable to make the database changes only during the setup.