.env file not present and readable

Followed the “Setup with Docker: Advanced” guide. Getting the following message when I go to localhost.

I tried to chmod 775 the .env file as well later on. Didn’t change a thing.
image

How my .env file looks:

LinkAce setup (please complete the following information):

  • Version: 1.0.1
  • Installed via: Docker
  • OS: WSL2 “20.04.1 LTS (Focal Fossa)”

Desktop (please complete the following information if applicable):

  • OS: Windows 10
  • Browser brave
  • Version V1.18.77

Hi!
Please try a 777 permission (write for all) while running the setup, you can switch back to restrictive permissions directly after finishing the installation.

Embarrassing of me not to notice a simple thing. Thought I did it already, but I did chmod 775 instead… Thanks so much!

I still got a 500 error later on when trying to make my account. Not sure why, but instead of bothering you I think I should take the time to try and learn docker and these other things.

I appreciate the program and hope to use it in the future!

If you receive 500 errors please share them with us. Details can be found under /storage/logs. If there are no logs, this directory is probably not writable.

I took the docker down before. Saw your message to get the log so I tried bringing it back up again, but now getting this error.

Looks more like some internal Docker issue to me. Did you solve that problem already?

Not at the moment. I’m gonna take the time to actually learn some Docker first then get onto this. I appreciate your help and will get back some time later to use the software.

Thanks again for the software. Will be stoked to finally have a place to organize my links efficiently.

1 Like