Docker install failure

Description of the Issue
I tried to install Docker version 1.10, which unfortunately failed.

What did I do:
I followed the “Setup with Docker: Simple” guide.

copied the following files:

docker-compose.production-simple.yml
.env.docker.production
nginx-simple.conf

renamed these files as intended and chmod .env to 777
I did NOT change the passwords.

docker-compose up -d
docker exec linkace_app_1 php artisan key:generate

After that logon via the IP address




I did not get any further…
also the installation “Setup with Docker: Advanced” did not work. However, the error message was different…

Description of the Issue
There seems to be a problem with the database.

LinkAce setup (please complete the following information):

  • Version: [e.g. 0.0.43]
  • Installed via: [e.g. PHP, Docker]
  • Distributor ID: Debian
    docker Description: Debian GNU/Linux 10 (buster)
    Release: 10
    Codename: buster
  • Docker version 20.10.2, build 2291f61
  • docker-compose version 1.27.4, build 40524192

Desktop (please complete the following information if applicable):

  • Windows 10 64bit german
  • Firefox, Opera, MS Edge (latest Versions)

LOG from Docker-Compose
[email protected]:/opt/LinkAce# docker-compose logs

Attaching to linkace_app_1, linkace_db_1
app_1 | -> Executing /opt/docker/provision/entrypoint.d/05-permissions.sh
app_1 | -> Executing /opt/docker/provision/entrypoint.d/20-nginx.sh
app_1 | -> Executing /opt/docker/provision/entrypoint.d/20-php-fpm.sh
app_1 | -> Executing /opt/docker/provision/entrypoint.d/20-php.sh
app_1 | -> Executing /opt/docker/bin/service.d/supervisor.d//10-init.sh
app_1 | 2021-01-17 14:07:18,247 INFO Included extra file “/opt/docker/etc/supervisor.d/cron.conf” during parsing
app_1 | 2021-01-17 14:07:18,247 INFO Included extra file “/opt/docker/etc/supervisor.d/dnsmasq.conf” during parsing
app_1 | 2021-01-17 14:07:18,247 INFO Included extra file “/opt/docker/etc/supervisor.d/nginx.conf” during parsing
app_1 | 2021-01-17 14:07:18,247 INFO Included extra file “/opt/docker/etc/supervisor.d/php-fpm.conf” during parsing
app_1 | 2021-01-17 14:07:18,247 INFO Included extra file “/opt/docker/etc/supervisor.d/postfix.conf” during parsing
app_1 | 2021-01-17 14:07:18,247 INFO Included extra file “/opt/docker/etc/supervisor.d/ssh.conf” during parsing
app_1 | 2021-01-17 14:07:18,248 INFO Included extra file “/opt/docker/etc/supervisor.d/syslog.conf” during parsing
app_1 | 2021-01-17 14:07:18,248 INFO Set uid to user 0 succeeded
app_1 | 2021-01-17 14:07:18,261 INFO RPC interface ‘supervisor’ initialized
app_1 | 2021-01-17 14:07:18,261 INFO supervisord started with pid 1
app_1 | 2021-01-17 14:07:19,264 INFO spawned: ‘syslogd’ with pid 50
app_1 | 2021-01-17 14:07:19,266 INFO spawned: ‘nginxd’ with pid 51
app_1 | 2021-01-17 14:07:19,269 INFO spawned: ‘php-fpmd’ with pid 52
app_1 | 2021-01-17 14:07:19,272 INFO spawned: ‘crond’ with pid 53
app_1 | -> Executing /opt/docker/bin/service.d/syslog-ng.d//10-init.sh
app_1 | 2021-01-17 14:07:19,280 INFO success: nginxd entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
app_1 | 2021-01-17 14:07:19,285 INFO success: php-fpmd entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
app_1 | 2021-01-17 14:07:19,285 INFO success: crond entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
app_1 | -> Executing /opt/docker/bin/service.d/cron.d//10-init.sh
app_1 | -> Executing /opt/docker/bin/service.d/nginx.d//10-init.sh
app_1 | -> Executing /opt/docker/bin/service.d/php-fpm.d//10-init.sh
app_1 | Setting php-fpm user to application
app_1 | [2021-01-17T14:07:19.372123] WARNING: With use-dns(no), dns-cache() will be forced to ‘no’ too!;
app_1 | [SYSLOG] syslog-ng[50]: syslog-ng starting up; version=‘3.19.1’
app_1 | [17-Jan-2021 14:07:19] NOTICE: fpm is running, pid 52
app_1 | [17-Jan-2021 14:07:19] NOTICE: ready to handle connections
app_1 | 2021-01-17 14:07:20,526 INFO success: syslogd entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
db_1 | mariadb 14:07:16.97
db_1 | mariadb 14:07:16.98 Welcome to the Bitnami mariadb container
db_1 | mariadb 14:07:16.98 Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-mariadb
db_1 | mariadb 14:07:16.99 Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-mariadb/issues
db_1 | mariadb 14:07:16.99
db_1 | mariadb 14:07:16.99 INFO ==> ** Starting MariaDB setup **
db_1 | mariadb 14:07:17.03 INFO ==> Validating settings in MYSQL_/MARIADB_ env vars
db_1 | mariadb 14:07:17.04 INFO ==> Initializing mariadb database
db_1 | mariadb 14:07:17.07 INFO ==> Updating ‘my.cnf’ with custom configuration
db_1 | mariadb 14:07:17.07 INFO ==> Setting user option
db_1 | mariadb 14:07:17.09 INFO ==> Setting collation_server option
db_1 | mariadb 14:07:17.10 INFO ==> Using persisted data
db_1 | mariadb 14:07:17.18 INFO ==> Running mysql_upgrade
db_1 | mariadb 14:07:17.19 INFO ==> Starting mariadb in background

Addendum

db_1 | mariadb 14:57:27.30 Welcome to the Bitnami mariadb container
db_1 | mariadb 14:57:27.30 Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-mariadb
db_1 | mariadb 14:57:27.30 Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-mariadb/issues
db_1 | mariadb 14:57:27.31
db_1 | mariadb 14:57:27.31 INFO ==> ** Starting MariaDB setup **
db_1 | mariadb 14:57:27.33 INFO ==> Validating settings in MYSQL_/MARIADB_ env vars
db_1 | mariadb 14:57:27.34 INFO ==> Initializing mariadb database
db_1 | mariadb 14:57:27.36 INFO ==> Updating ‘my.cnf’ with custom configuration
db_1 | mariadb 14:57:27.37 INFO ==> Setting user option
db_1 | mariadb 14:57:27.38 INFO ==> Setting collation_server option
db_1 | mariadb 14:57:27.38 INFO ==> Using persisted data
db_1 | mariadb 14:57:27.42 INFO ==> Running mysql_upgrade
db_1 | mariadb 14:57:27.43 INFO ==> Starting mariadb in background
db_1 | mariadb 15:07:28.34 ERROR ==> MySQL failed to start

Hi!
Please remove MARIADB_COLLATE=utf8mb4_bin from the database configuration in the docker-compose file and try again.

I have installed version 1.2.0. That worked. Thank you.

1 Like